Having trouble installing Publisher IQ9 on macOS Catalina? Are you getting the error:

"Java for macOS 2017-001 can't be installed on this disk. A newer version of this package is already installed."

This is because Publisher is dependent on an older version of Java to operate, and we'll need to override blocking the installation of the older version.

To do this, you'll need to perform the following:

  1. Download the legacy Java 6 runtime from support.apple.com
  2. Download the script below and run it on your affected device

3. When prompted, select the installer downloaded from step 1

4. Install Publisher IQ9

If you're still having issues, don't hesitate to start a chat with us!

Did this answer your question?